手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

Linux Kernel 'fs/userfaultfd.c'本地释放后重利用内存破坏漏洞(CVE-2017-15126)

[日期:2018-01-22] 来源:Linux社区  作者:Linux [字体: ]
Linux Kernel 'fs/userfaultfd.c'本地释放后重利用内存破坏漏洞(CVE-2017-15126)


发布日期:2018-01-10
更新日期:2018-01-22

受影响系统:

Linux kernel < 4.13.6

描述:


BUGTRAQ  ID: 102516
CVE(CAN) ID: CVE-2017-15126

Linux Kernel是Linux操作系统的内核。

Linux kernel < 4.13.6版本,fs/userfaultfd.c存在释放后重利用漏洞,成功利用后可使本地攻击者在内核上下文中执行任意代码。

<*来源:Mark Rutland
  *>

建议:


厂商补丁:

Linux
-----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:


https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=384632e67e0829deb8015ee6ad916b180049d252
https://github.com/torvalds/linux/commit/384632e67e0829deb8015ee6ad916b180049d252

本文永久更新链接地址http://www.chineselinuxuniversity.net/Linux/2018-01/150484.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款