手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

yii2手动添加插件PHPExcel

[日期:2018-01-23] 来源:Linux社区  作者:JahanGu [字体: ]

yii2手动添加插件PHPExcel

1.下载地址:https://github.com/PHPOffice/PHPExcel

2.解压并修改文件名为phpexcel

之后在yii项目的vendor目录下创建一个文件夹命名为phpoffice

把phpexcel文件放到phpoffic文件夹下

此时查看vendor\phpoffice\phpexcel目录下会看到这些文件

 3.到vendor\composer目录下修改文件autoload_namespaces.php,

添加一句代码注册命名空间

'PHPExcel' => array($vendorDir.'/phpoffice/phpexcel/Classes'),

如图:

接下来就可以开始使用了;

    //excel导入函数
    public function import($fileName){

        $objReader = new \PHPExcel();
     
        $file = $fileName;       
        $objPHPExcel = \PHPExcel_IOFactory::load($file); 
        $allSheet = $objPHPExcel->getSheetCount();
        for($i=0; $i<$allSheet;$i++){
            $dataSheet = $objPHPExcel->getSheet($i)->toArray('', true, true);
            if(!$this->saveData($dataSheet)) return '0';

        }

        return '1';
    } 

使用方法是直接   $objReader = new \PHPExcel();

记住实例化时前面要加 \  

以上只是我自己写的例子,本教程是写怎么手动引入PHPExcel插件的,具体用法就不作多介绍了,可自行百度;

注意执行下面步骤需备份文件,以防万一:

php版本大于5.6可能会报错找不到该类;

如要支持就需要修改vendor\composer目录下的autoload_real.php文件

把关于$useStaticLoader这个变量的if判断的代码都删了;如下图红框标识的代码都删了; 

之后再把vendor\composer目录下的autoload_static.php文件删了,就可以支持更高版本的php了; 

注意看>= 50600那部分的代码就明白为什么php版本大于5.6可能会报错找不到该类;

本文永久更新链接地址http://www.chineselinuxuniversity.net/Linux/2018-01/150510.htm

linux
相关资讯       Yii2  PHPExcel 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款